Category FTP

Autobackup Mikrotik : Kirim File Backup Ke Ftp Server Otomatis

Melakukan backup konfigurasi Mikrotik secara rutin dapat mengurangi resiko downtime yang usang alasannya ialah harus konfig ulang router ketika terjadi problem pada router tersebut. Setidaknya jikalau router rusak, atau RouterOS nya corrupt, kita tidak perlu repot-repot lagi ngonfig dari awal. Tinggal restore saja konfigurasi nya dari file backup yang sudah disimpan sebelumnya.
Namun masalahnya kadang kita terlalu malas untuk sekedar melaksanakan backup konfigurasi dan menyimpan nya. Sama malasnya menyerupai saya yang harus me-manage puluhan Router Mikrotik. Capek kalau harus backup konfig satu per satu, hehe :D. 
Sebenarnya pada Tutorial Mikrotik sebelumnya sudah pernah saya bahas ihwal :
Tutorial Mikrotik kali ini merupakan pengembangan dari tutorial tersebut, dimana file backup dan export yang sudah di generate bukan dikirimkan ke Email, namun di upload ke Folder di FTP Server secara otomatis dan terjadwal. Sehingga file backup & export yang di upload ke FTP akan tersusun rapi, gampang ditemukan, dan cepat dapat digunakan. Contoh nya menyerupai ini :
Oke cukup sudah kisah sebelum tidurnya, kebanyakan baca prolog ntar malah jadi ngantuk :p mari kita pribadi saja bahas caranya. Disini kita akan manfaatkan Tool Fetch Mikrotik untuk melaksanakan proses upload file. Selain itu kita juga akan gunakan Script & Scheduler untuk otomasi nya.

Tutorial Cara AutoBackup Mikrotik : Kirim File Backup ke FTP Server Otomatis

1. Pastikan kita punya jalan masuk ke FTP Server untuk menciptakan direktori lokasi upload file backup.
2. Login via Winbox Mikrotik –> Pastikan Mikrotik nya sudah dapat ping ke FTP Server.
3. Buat Script Auto Backup Mikrotik. Masuk ke sajian System –> Scripts –> Tambahkan Script gres –> Beri nama autobackup –> pada kolom Source isikan :

/system backup save name=(“BACKUP” . “-” . [/system identity get name] . “-” .
[:pick [/system clock get date] 4 6] . [:pick [/system clock get date] 0 3] . [:pick [/system clock get date] 7 11]);
/export file=(“BACKUP” . “-” . [/system identity get name] . “-” .
[:pick [/system clock get date] 4 6] . [:pick [/system clock get date] 0 3] . [:pick [/system clock get date] 7 11]);

Contoh nya menyerupai gambar berikut :
Script ini jikalau di run akan men-generate file backup (.backup) dan file export (.rsc) dengan format penamaan yang gampang dikenali.
4. Buat Script lagi untuk proses upload file backup. Disini kita akan buat dua script terpisah untuk proses upload file .backup dan .rsc. Untuk script upload file backup beri nama uploadbackup –> Script source nya sebagai berikut :

:global backupname (“BACKUP” . “-” . [/system identity get name] . “-” .
[:pick [/system clock get date] 4 6] . [:pick [/system clock get date] 0 3] . [:pick [/system clock get date] 7 11] . “.backup”);
/tool fetch address=Alamat.FTP mode=ftp user=Username.FTP password=Password.FTP src-path=$backupname dst-path=”Direktori.FTP/$backupname” upload=yes

Silakan ubah data yang ditandai kuning dengan data Anda sendiri. Contoh nya sebagai berikut :
5. Script ini dibentuk untuk proses upload file export (.rsc) –> Beri nama uploadrsc –> Isikan Source dengan script berikut :
:global backupname (“BACKUP” . “-” . [/system identity get name] . “-” .
[:pick [/system clock get date] 4 6] . [:pick [/system clock get date] 0 3] . [:pick [/system clock get date] 7 11] . “.rsc”);
/tool fetch address=Alamat.FTP mode=ftp user=Username.FTP password=Password.FTP src-path=$backupname dst-path=”Direktori.FTP/$backupname” upload=yes
Contoh nya menyerupai gambar berikut ini :
6. Selanjutnya kita coba Run kedua Script upload tersebut. Coba cek pada folder tujuan upload di FTP Server. Jika konfigurasi script sudah benar, seharusnya akan muncul file .backup dan .rsc menyerupai gambar berikut ini :
Jika belum muncul file backup nya, silakan cek lagi data pada script nya. Pastikan username dan password FTP nya punya hak jalan masuk Permission Read/Write (RW) pada folder tujuan upload. 
7. Sekarang saatnya mambuat penjadwalan, sehingga script tersebut dapat dijalankan secara otomatis dan terjadwal. Kita gunakan Scheduler, masuk ke sajian System –> Scheduler –> buat 3 scheduler  gres untuk masing-masing script yang sudah kita buat.
Disini saya contohkan untuk menciptakan script dijalankan secara otomatis pada 01 Maret 2017 dengan interval 30 hari, jadi script ini akan berjalan mulai tanggal 1 Maret 2017 dan akan jalan otomatis tiap 30 hari.
Pastikan ketiga script tersebut tidak diekseskusi secara otomatis pada waktu yang bersamaan. Dahulukan script autobackup, gres kemudian script uploadbackup dan uploadrsc. Contoh konfigurasi nya silakan lihat gambar berikut :
Nah, kini tinggal konfig Router Mikrotik lainnya untuk auto backup ke FTP Server juga. Gak problem capek konfig di awal, asal kedepanya gak capek tiap bulan ngumpulin file backup satu per satu :D.
Read More